This plugin hasn’t been tested with the latest 3 major releases of WordPress. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Velvet Blues Update URLs

Beskrywing

If you move your WordPress website to a new domain name, you will find that internal links to pages and references to images are not updated. Instead, these links and references will point to your old domain name. This plugin fixes that problem by helping you change old urls and links in your website.

Features:

  • Users can choose to update links embedded in content, excerpts, or custom fields
  • Users can choose whether to update links for attachments
  • View how many items were updated

Screenshots

  • The Admin screen for the plugin. screenshot-1.png

Installation

Installation and uninstallation are extremely simple. You can use WordPress’ automatic install or follow the manual instructions below.

Installing:

  1. Download the package.
  2. Extract it to the “plugins” folder of your WordPress directory.
  3. In the Admin Panel, go to “Plugins” and activate it.
  4. Go to Tools -> Update URLs to use it.

Uninstalling:

  1. In the Admin Panel, go to “Plugins” and deactivate the plugin.
  2. Go to the “plugins” folder of your WordPress directory and delete the files/folder for this plugin.

Usage:

Using this plugin is very simple. Once it has been activated, navigate to Tools -> Update URLs and follow the instructions. Please Note: Changes are irreversible. If you haven’t used this plugin before, please backup your website before proceeding.

You can also contact us for assistance. Velvet Blues will backup your website and replace your URLs for only $29. If you need your website moved, we charge a flat fee of $75 and will finish your move within 48 hours – week days only. For same-day or weekend jobs, we charge a flat rate of $125. Contact us at info@velvetblues.com for more information.

Kwel-vrae

Why are my urls not updated?

URLs are only replaced when an exact match is found. Be sure that you have entered the correct url and hit submit. (Note: Matching is case-sensitive.)

Why do I see the message “You do not have sufficient permissions to access this page”?

Make sure that the plugin is activated and that you are an administrator level user.

This plugin saved me a lot of work. Where can I donate?

Thanks, donations help us to continue improving our plugins. Donate Here via PayPal.

I’m afraid to screw this up. Will you do it for me?

Of course! Velvet Blues will backup your website and replace your URLs for only $39. If you need your website moved, we charge a flat fee of $75 and will finish your move within 48 hours – week days only. For same-day or weekend jobs, we charge a flat rate of $125. Contact us at info@velvetblues.com for more information.

Aanbevelings

Oktober 1, 2021
Very good solution. It can change any URL position in all website. For example? from site.com/best to site.com/verybest. It is good solution for URL with refferal codes. Also great solution in the case of change domain. For example, from site.com to site2.com
Julie 17, 2021
I can examine the code, create the code and edit the code - I thought this would save time so tested it and attempted to update localhost links within a page to the live environment links. It failed to find any of the links.
Mei 8, 2021
Thanks to the plugin author for providing such a simple and great plugin for totally free of cost! It is really handy when someone needs to shift or migrate their website from one domain to another. Best regards, Atiqur Rahman, BloggerATIQ.com
Read all 254 reviews

Contributors & Developers

“Velvet Blues Update URLs” is oopbron sagteware. Die volgende mense het bygedra tot die ontwikkeling van hierdie uitbreiding:

Contributors

“Velvet Blues Update URLs” has been translated into 17 locales. Thank you to the translators for their contributions.

Translate “Velvet Blues Update URLs” into your language.

Interested in development?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Changelog

3.2.10

  • Confirmed compatibility with WordPress 5.2.x, 5.3.x, 5.4.x and 5.5.x releases.
  • Version Update.

3.2.9

  • Confirmed compatibility with WordPress 5.1.x releases.
  • Version Update.

3.2.8

  • Confirmed compatibility with WordPress 4.9.x releases.
  • Version Update.

3.2.7

  • Maintenance Update.

3.2.6

  • Tested with 4.6.
  • Version Update.

3.2.5

  • Updated label ID for better UX when selecting url location options.
  • Added use if is_serialized() to remove PHP NOTICES about offsets during url update process.
  • Confirmed compatibility to with WP 4.6 and updated stable tag.

3.2.3

  • Confirmed compatibility with WordPress 4.0.x releases.
  • Updated readme file.

3.2.2

  • Relocated Update URLs tab to Tools section. It is now found under Tools->Update URLs
  • Added additional serialization checks for postmeta.

3.2.1

  • Bug fixes.
  • Added Turkish language file.

3.2

  • Confirmed compatibility with WordPress 3.6.x releases.
  • Added option to replace urls within Links.
  • Updated success and error dialogs and other text throught plugin.

3.1

  • Confirmed compatibility with WordPress 3.5 release.

3.0

  • Confirmed compatibility with latest WordPress releases and added support for future versions.
  • Redesigned interface.
  • Added the ability to update links in custom fields.
  • Improved security against potential cross-site attacks by adding nonces and a referrer check and added exit to script if accessed directly.
  • New error messages and field validation.
  • Made changing ALL GUIDs optional, and turned off by default.
  • Internationalized plugin.
  • Updated License to GPLv2 or later.
  • Fixed Typos

2.0.1

  • Confirmed compatibility with WordPress 3.1.x releases.
  • Updated FAQs and Contributors.

2.0

  • Added the ability to update links in excerpt fields.
  • Updated code for full compatibility with WordPress 3.0 releases.

1.0.3

  • Confirmed compatibility with recent WordPress releases.

1.0.2

  • Fixed PHP short tag problem, so as to be compatible with all configurations.

1.0.1

  • Fixed possible interactions with other plugins.